backwards compatibility

Best this I've read so far this morning: "Your Mac OS may not be fully compatible with this website."

Um, hello? Who is a little bit backwards here?